请选择 进入手机版 | 继续访问电脑版

每天都有无数事情发生,每天都曾在游戏历史上留下记录。游戏史上的今天,带你每天回顾这个日子的历史事件,回味经典诞生的瞬间。

酷站网 首页 站长学院 Discuz教程

Discuz!应用中心安装模板提示版本号不匹配的解决方法

2017-7-17 19:34 78 0 原作者: 酷站小编 来自: 互联网编辑
简介
有时候我们从应用中心安装模板,在应用中心里模板作者设定允许我们的程序版本,但是我们安装时却提示版本号不匹配,那这是为什么呢?经过我们分析发现是因为X3和X3.1,X3.2的模板是完全兼容的,很多模板是在X3的时候 ...
有时候我们从应用中心安装模板,在应用中心里模板作者设定允许我们的程序版本,但是我们安装时却提示版本号不匹配,那这是为什么呢?经过我们分析发现是因为X3和X3.1,X3.2的模板是完全兼容的,很多模板是在X3的时候发布,而且之前的机制里一直是即使版本号不同,用户依然可以强制安装,但是,从X3.1后期开始,官方自己把自己的规矩改了,用户没有办法强制安装了,很多作者也没有在意这点,而且应用中心模板的审核与发布、更新的周期更让作者们苦等。 下面我们以discuz! X3的qing模板安装在X3.2上为例子讲解。 首先说的是错误提示图,如下图所示,官方发布的升级版版本号还是X2.5的,不过这不影响我们演示: Discuz!应用中心安装模板提示版本号不匹配的解决方法 我们打开template/qing(其他模板为其他模板的目录)/discuz_style_qing.xml文件,在里面找到X2.5, 如果错误图提示为什么版本就搜什么版本,通常能搜索到至少两处 修改成自己的版本然后保存,重新在后台,界面,风格设置处安装模板即可。 本文由酷站源码网整理发布,转载请说明出处:http://www.ekuzhan.com

鲜花

握手

雷人

路过

鸡蛋
精彩阅读 更多
广告位

400-888-8888

周一至周五 9:30-18:00

北京市大兴区景园北街2号02号

  • 扫一扫 手机访问

Archiver-手机版-小黑屋- 酷站网.  

Powered by Discuz!X3.3© 2012-2018 Comsenz Inc. 版权所有